Instalare bwm-ng in pfsense

(Postarea e un note to self, dar poate ajuta si pe altii.)

Imi place sa monitorizez traficul de retea pe Linux cu bwm-ng. Stiu ca exista alternative (iftop, vnstat, nmon, etc, etc) dar eu prefer bwm-ng. E un utilitar misto, simplist, ce arata traficul pe fiecare interfata in parte + un total. Something like this:

In Linuxuri e usor de instalat pentru ca exista in repo-uri. In FreeBSD e la fel de usor de instalat ca si in Linux, dar in pfsense nu exista in repo-uri. Nu putem instala prin pkg install pentru ca pfsense nu foloseste repo-urile FreeBSD, dar putem sa ne folosim de pkg add.

pkg add https://pkg.freebsd.org/FreeBSD:11:amd64/quarterly/All/libstatgrab-0.92.txz
pkg add https://pkg.freebsd.org/FreeBSD:11:amd64/quarterly/All/bwm-ng-0.6_2.txz

That’s it. Pachetul libstatgrabe dependinta pentru bwm-ng, de asta il instalam primul.

About Author:

I look 12, but I'm a 42-year-old investment banker!

3 thoughts on “Instalare bwm-ng in pfsense

      1. Dragut echipament, intotdeauna ai avut ochi pentru asa ceva.
        Ai cumva setate doua exit (public) interfaces (in poza de mai sus par sa fie cu trafic pe ele doar unul public si unul private) ?
        Porturile gigabit stiu de vlan-uri, nu ?
        Sata-ul e nativ sau ai bridge usb-to-sata ?
        Din cauza asta am renuntat de anul trecut sa ma mai gindesc la un router de la BPI (inca nu mi-am luat MikroTik); unul dintre board-urile produse de ei mi-a pus pe dreapta un ssd sata3 ce-l atasasem pentru Samba. Vechea poveste cu ‘SATA AHCI Phy Calibration Failed’. Viteza, atasat fiind apoi la un sistem desktop, era infecta (10-17MB/s) si dupa un timp (la wipe/dd) se pierdea comunicatia dintre host si drive, insa nu apareau bad-uri (zero wearing). L-am rezolvat in cele din urma. Nu e documentata niciunde rezolvarea. Producatorul ssd-ului a gasit de cuvinta sa-mi zica ca nu mai e in garantie, deci zero suport si chiar daca ar fi fost inca in garantie, mi l-ar fi inlocuit. Acum ssd-ul merge de rupe la fel de repede fara erori, iar la BPI-ul cu pricina am atasat un hdd ordinar sata2 de 2.5″ @5.4k rpm (ca sa nu ma zapaceasca de cap) si sa nu mai existe problema PHY-ului.
        In tot cazul, foarte tare board-ul tau. Scuze pentru textul lung de mai sus si pentru ca mi-am permis sa te contactez zilele trecute pe numarul cu 225 in coada.

Lasă un răspuns

Adresa ta de email nu va fi publicată. Câmpurile obligatorii sunt marcate cu *

Acest sit folosește Akismet pentru a reduce spamul. Află cum sunt procesate datele comentariilor tale.